Today, i arrived at work to find one of my two production WFEs became inaccessible to end users “500 internal server error”. When reviewing the health analyser in CA I got the warning that “the security token service is unavailable” When I reviewed the ULS and Event Logs, I noticed that I get a lot of the following errors, (1100 since 5:07pm 19/12 AEDT)

“Windows Event 8306 – Claims Authentication An Exception occurred when trying to issue security token: An error occurred while making the http request to http://localhost:32843/SecurityTokenServiceApplication/securitytoken.svc(/actas). This could be due to the fact that the server certificate is not configured properly with HTTP.SYS in the HTTPS Case. This could also be caused by a mismatch of the security binding between the client and the server..”

Everything worked just fine prior to 5:07pm (I left work at 5pm) and it is only happening on one server, the other wfe and app servers are fine.

All servers are Patched to November 2018 CU and were windows OS patched that morning (4am) to patches released for December 2018. My Pre-Prod and QA environments are chugging along perfectly without any mention of the above error. I’ve tried to re-provision the service - no luck I’ve tried to update the web.config to include - no luck... I’ve confirmed that securitytokenserviceapplication web.config file is identical to other WFE...

I’m lost.

Any advice our community can provide is always appreciated!

  • have you tried to recycle the App Pool of STS service? was it started or stoped? have you check Event logs (System and Setup category as well)...When you browse the URL mentioned in error on the server what you get?
    – Waqas Sarwar MVP
    Dec 20, 2018 at 13:38
  • I have tried to recycle the app pool, restarted the server a number of times as well. Everything is in a started state and “appears” to be “functional”. When clicking the URL no page returns at all, just an IE file not found. The event logs show the WebHost failing at 5:07 but that’s about it. I will confirm when I’m back in the office
    – Rjsmith
    Dec 20, 2018 at 18:09

1 Answer 1


What I ended up doing was removing the server from the SharePoint farm, restarted the server (to ensure all changes took effect) then re-added the server back to the farm. It appears that there was a problem with that servers Configuration, so re-adding it meant we could pull functional config from the config database.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.