1

We have aprox 700+ site collections in our Production on-prem 2013 environment. Is there a way to send the administrator an email every time a user gets access denied page and writes why he/she needs access?

http://SharePointURL/Acces%20requests/pendingreq.aspx


EDIT We already have Outgoing E-mail Setting configured We have a relay server, and a group mailbox that we want to be the sender and recipient.

We also have the "Access request settings" configured. Trorubble is that nothing is happening when we Request access to a page that we dont have access to our mailbox that is configured to receive emails isnt receiving any emails about a new request.

enter image description here

enter image description here

4 Answers 4

1

Figured out what was wrong.

There was no SMTP service running. After i installed and configured it i then used Servers domain alias and added it into the host file of the server where i installed the SMTP. After that i added my "SMTP" servers IP adrese to all my other Web front servers host files.

And now Emails to my admin work.

0

In the screenshot you mentioned above "Write your business reason", and also include if you have the list of sites that you are needing access & mention your business reason for each of it and hit send request. So that admin can have a proper decision on your request.it also helps his audit.

1
  • This doesnt solve my problem. The admin doesnt get an email. they have to go inside Access requests and invitations to see what ppl are accessing and then figure out if that is ok to do. Im looking for a way that the Admin DOESNT have to do anything other than open his own email and see that somebody is requesting access.
    – Cherubel
    Commented Dec 17, 2018 at 10:09
0

Open Site Settings -> Then Click on Site Permissions -> From Ribbon (Permission Tab) Click on Access Request Settings.

This will open up a dialog window where you can specify the email address.

For more information check below article:

Set up and manage access requests.

1
  • This i already did. But the mails arent getting through. Email routing is also turned on.
    – Cherubel
    Commented Dec 17, 2018 at 10:12
0

Navigate to Site Settings ->Site Permissions ->Access Request Settings->Allow access request:

enter image description here

then user will receive access request email:

enter image description here

For your issue, make sure outgoing email is working fine in your farm.

Make sure the user has valid email address.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.