1

I have a SharePoint 2016 on-premises farm that had recently crashed. I had to rebuild the farm, but was able to recover the WSS_Content database and get all the sites back up and running. However, I have some search features on one site that are not working properly and I can't seem to figure out why. We have a document library that contains a large number of PDF files and several columns of text metadata that describe the PDF for searching.

When I first brought the site up, KQL searches were not working. I found out (thanks to the great users on this site) that my managed properties were not mapped to my crawled properties. I fixed this and searches started working. However, the site also had refiners set up using four of the fields and they are still not working properly. I found yesterday that the Refinable property on the managed property was set to No, so I went back and set it to "yes - active". I did a full re-index of the site and one of the properties began showing up in the refiners section of the search. However, the other three properties are still not showing up. When I edited the web part to check that the properties were added, it was showing them as added to the list, but that no data was available. Can anyone help lead me in the right direction to get this working?

  • Are you certain that there is data in the columns for the refinable data and that the crawls are finding the documents? Check your crawl logs for the items by URL. – Matthew McDermott Dec 12 '18 at 12:19
  • There is data and the documents are showing up in the crawl log. – DrewB Dec 12 '18 at 21:38
  • The next step would be to determine if your Result Sources are to blame. You can use the SharePoint Search Query Tool to run queries and test if the documents are returned without a Search Center. If the queries work then you know it's your search site and not SharePoint. – Matthew McDermott Dec 13 '18 at 13:37
  • Last night, just on a hunch, I created an index on each of the properties that were supposed to be showing up and did a full reindex of the site. Afterward, three of the four are showing up as refiners. The fourth one still is not. – DrewB Dec 13 '18 at 14:35
  • Also, I've tried searching using "Image Number":234 and I don't get any results back. I've sorted and I know the list contains Image Numbers that contain 234. – DrewB Dec 13 '18 at 14:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.