1

I am trying to create a workflow that runs when a new item is created. Basically, I want to send an email notification that includes the ID value (of the list item) when a new list item is saved/submitted. However, the workflow works and an email will be sent but ID field value from body of email is blank...although when I go back to the lists, value has already been assigned to ID field.

Can somebody assists me on how the workflow be setup to have the ID field get its value, before the "send email" action in the workflow get triggered? so that when email is sent out it will show the ID field value assigned to the list item.

Workflow

And the email sample is below;

Email sample

Thank you.

0

Did you add your workflow on On item creating event? if yes then change it to on item created event, after that, you can able to get the list item ID. Still, if you are not able to get the item ID then add "pause until" action of some seconds and place that action before send email action in On item created event.

  • The Pause until action seems to fix my issue. Thank you. – Newbie Dec 11 '18 at 15:35
0

List Item ID is generated immediately after you creates item in list. Try setting your UniqueNo variable before IF Statement.

Check below image for reference:

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.