2

After trying to install the update, my windows service "Service Bus message broker struck in starting state. From the logs, i found the error.

Complete-WFHostUpgrade : The remote server returned an error: (404) Not Found. The incoming request is not recoginzed as a namespace policy put request: Unrecognized policy type: SubscriptionDescription, http://schemas.microsoft.com /netservices/2010/10/servicebus/connect.TrackingId:47baa270-c316-4c71-a7ad-e75d 0a577d22_Gshrd-rlg-spap3s,TimeStamp:12/10/2018 9:12:13 PM At C:\ProgramData\Microsoft\E-Business Servers Updates\Updates\Uninstall4055730\UnifiedWFHotfixUpgrade.PS1:643 char:5 + Complete-WFHostUpgrade -TargetWFVersion $TargetWFVersion + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ + CategoryInfo : WriteError: (:) [Complete-WFHostUpgrade], Messag ingEntityNotFoundException + FullyQualifiedErrorId : WFServiceUpgradeFailed,Microsoft.Workflow.Deploy
ment.Commands.CompleteWFHostUpgrade

3

Looks like permission issue, Please make sure Service accounts (Running the services) has right permission on the Workflow & Service Bus databases.

also try to stop the SB host and then start it. using Stop-SBHost & Start-SBHost.

  • it is running with an installation account which has admin permissions. "Stop-SBHost" didnt finish execution, probably because service "Service Bus message broker" was stuck in starting state. – Achiever SP Dec 10 '18 at 21:48
  • few blogs showed installing "Workflow manager 1.0 refresh (CU2)" from web platform fixes the issue, but i am already on Workflow manager Cumulative Update 5, installed successfully. – Achiever SP Dec 10 '18 at 21:50
  • 1
    try to restart the server – Waqas Sarwar MVP Dec 10 '18 at 22:07
  • Did couple of times, but still the service is stuck in starting State – Achiever SP Dec 10 '18 at 22:13
  • Do u have azure service bus 1.1 update installed – Waqas Sarwar MVP Dec 10 '18 at 22:18
1

Please make sure that the Windows Fabric Host Service is running.

If the Windows Fabric Host Service is not running, please start it, then try to start the Service Bus Message Broker again.

If you cannot stop the broker service while starting, got to task manager and kill Microsoft.ServiceBus Message Broker process.

References:

https://developers.de/blogs/damir_dobric/archive/2012/09/18/servicebus-message-broker-service-is-starting-and-starting.aspx

Service Message broker services in Starting - SharePoint 2013

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.