3

I currently have a list workflow configured to send users an email based on some conditions.

Within this email, I'd like the title of the list item to display to the user so they know what the email is referring to.

I've read elsewhere that you can use something like this in your email's body of text:

[%Current Item: Title%]

In theory, this should retrieve the title value and display it in the email. However, the email is simply displaying this piece of code as plain text and not retrieving anything.

Would be grateful for anyone's help.

4

There is a space between Item: and Title%!

You should use it without space like this [%Current Item:Title%]

Below is the correct way to get instead of adding it manually

  • At subject, Click on eclipse ....
  • Add or Change Lookup.
  • Current Item > Title.

enter image description here

Note: you can also use Fx button to show the title as a subject without adding any additional text.

enter image description here

  • I have removed the space and also tried using the 'add or change lookup' option to select the title column. When the user receives the email, the email now doesn't display anything at all, not even the plain text of [%Current Item:Title%]. I noticed this person seemed to have a similar issue, but I was a little confused by their solution, unless you might understand it better? sharepoint.stackexchange.com/questions/160228/… – Toby Dec 10 '18 at 11:08
  • Have you tried another field? are you sure the field content is not empty!? – Mohamed El-Qassas MVP Dec 10 '18 at 11:12
  • Yes, I've just tried another field and again the lookup doesn't appear to display anything in the email. Both fields are definitely not empty. – Toby Dec 10 '18 at 11:21
  • Update: It seems there is an issue with SharePoint Designer saving and publishing the changes I am making. I changed the subject field to use the lookup like you said, but after publishing my changes the email notification is displaying the old text that used to be in the subject field before I added the lookup. In other words, for some reason my changes aren't being added to the site. – Toby Dec 10 '18 at 11:32
  • Try to clear the SharePoint designer cache stackoverflow.com/questions/43113666/… – Mohamed El-Qassas MVP Dec 10 '18 at 11:37

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.