2

I followed this

http://www.sharepointdiary.com/2013/09/migrate-from-sharepoint-2010-to-2013-step-by-step.html

Everything is fine (not error during upgrade either). However, user's in the permission groups still shows domain\username instead of claim based. If i add a new user then it shows i:0#.w|domain\davidhassel01

Since it's a 2013 site so the web app is already claimed based. I can't read the SP groups using powershell script.

The SP 2010 is classic and i can't just change it to claims because it's production site.

Any idea on how to fix this issue?

3

After working on this for past 3 days finally following steps helped

  1. I deleted all the users from _layouts/15/people.aspx?MembershipGroupId=0
  2. I then copied all the SharePoint groups from the source site to target site

Now all the users have proper permissions and they appear with the claim token.

Thanks Trevor for looking into this.

1

Re-run Convert-SPWebApplication. It is safe to re-run this.

  • I ran that so many times and still no good. – Ruby Trustit Dec 7 '18 at 19:07
  • Sorry, so you have Active Directory security groups nested in SharePoint Groups and for the users in the security groups who have not accessed the site (in other words, have no entry in the UIL) show up as 'domain\userName' when you perform a Check Permissions. Is that correct? – Trevor Seward Dec 7 '18 at 20:01
  • All the users in various list show up with domain\username – Ruby Trustit Dec 7 '18 at 20:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.