2

I have an oddly browser specific problem. I'm trying to delete some unwanted site columns from a content type. the content type is not yet in use anywhere. when I open to columns in the content type I see the delete button right where it should be but clicking on it does nothing. opening the site in firefox or IE the button performs normally.

It's as if JavaScript was disabled in Edge but google tells me that feature has been removed from the browser.

Any Ideas?

1

Out of curiosity, I have tried using Edge.

  • Created CT.
  • Added a column to CT
  • Removed column from CT.

All worked fine.

But the Remove button has a JavaScript onclickevent:

javascript:if(!ConfirmDelete()) return false;_....)

I think, your Edge blocks a popup (confirm) window and this is why it seems that nothing is happening when you click "Remove" button. enter image description here

Update: In order to avoid popups to be blocked try these two things:

  • Add your SharePoint site to the local intranet zone
  • Turn off Block pop-ups feature in Edge (see screenshot below). Settings-->Advanced Settings --> Block pop-ups --> Off

enter image description here

  • That's quite possible. any ideas on a workaround? – JonS Dec 7 '18 at 15:12
  • @JonS. Update the answer with two workarounds. – Denis Molodtsov Dec 7 '18 at 16:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.