0

I think I have found another odd thing using SharePoint 2013. I have a custom list that sends notification emails. There are 5 working SharePoint Designer workflows connected to it that are sent at different points as options in the form are picked. But there is one particular notification that's sent that is not connected to any of the 5 SharePoint Designer workflows. I checked if there is a Alert Me but I do not see that any have been created by checking site settings. I checked if a OTB workflow was added to the list - nope nothing. Things I noticed are that the From in the email is generated by SharePoint but it doesn't include the list title. For example, when you get a SharePoint Designer Workflow from a list it has the title of the list in the From part of the email address. I need to find the notification email to do edits.

Do anyone know what and where I am missing? Is there any place that I have not looked where I can locate the email notification?

1

May be mail was sent from list event receiver? You can check it with the SharePoint manager tool or with powershell.

Powershell code to see list event receivers:

#Get the web
$Web = Get-SPWeb "http://xxx"

#Get the Target List
$List = $Web.Lists["LISTNAME"]

#Retrieve all event receivers associated with the list
$List.EventReceivers | Select Id, Type, Assembly, Class | FL
  • If any list event receiver are found using the Powershell code, how do I locate? – SharePoint Lady Dec 6 '18 at 19:21
  • 1
    If any list event receiver are found you can remove it by adding following lines to the powershell code: $EventReceiverID = "GUID OF EVENT RECEIVER" $List.EventReceivers[[GUID]$EventReceiverID].delete() – Raf Dec 7 '18 at 12:51
  • 1
    You don't have ability to see event receivers via web interface. – Raf Dec 7 '18 at 12:54
  • Thanks. By deleting will this effect the 5 SharePoint Designer workflows? I double wanted to check. – SharePoint Lady Dec 7 '18 at 13:12
  • It depends on what custom server-side code contains in your event receivers. If there is only sending email function - it will not affect your workflows. Does you have Visual Studio and *.sln file of your project? Does you have any custom solutions(wsp) deployed in the farm? – Raf Dec 10 '18 at 4:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.