2

Scenario: SharePoint 2016 MinRole Farm with 2 Servers.

I tried starting Microsoft SharePoint Foundation Sandboxed Code Service in one and in both servers as I found this: Can't Activate Solution from Site Settings in SharePoint foundation 2010 and used the PS cmd:

$SA = Get-SPServiceInstance | Where {$_.Id -like “*GUID*”}
$SA.Provision()

This made that service start on the servers but shown as Not compliant in Central Administration>Services on Server. Anyway, by having this service running, it didn't make a difference and the Activate button kept been disabled for a new solution (template.wsp) I uploaded to the Solution Gallery.

Can you advise how to make the Activate button Enabled?

  • what are the role of servers FE, App or? – Waqas Sarwar MVP Dec 5 '18 at 14:58
  • 1 server: Application with Search and 1 server Front-End with Distributed Cache and I have SharePoint User Code Host Service running automatic under Services on both servers and Central Administration Services on Server is saying that is not Compliant. – MLC Dec 5 '18 at 21:46
1

Microsoft SharePoint Foundation Sandboxed Code Service compliant on the Front End, Front end with DC or Custom MinRole.

  • If you have any of the above role in your farm then you can enable the auto provision and start the services from central.
  • Also make sure that "SharePoint User Code Host" service is running on server (check via services on the computer)
  • If the service is started and the Activate button is not yet active you will need to elevate the privileges In the WebApplication UserPolicy, add the Service Account used for Microsoft SharePoint Foundation Sandboxed Code Service with Full Control rights.

Read more here: Enable Sandbox solutions on SharePoint 2016

  • The account being used to run the service is the farm account, which has Full control and Full read on the WebApp User Policy. Service is running on both servers. I didn't understand your first point of "can enable the auto provision and start the services from central." – MLC Dec 5 '18 at 21:51
  • check the link, i shared – Waqas Sarwar MVP Dec 5 '18 at 22:19
  • I carefully followed the steps in the link you shared. I autoprovisioned the service from CA and now the service is showing Compliant. I also changed the service account from the Farm account to the Services account which is another one with Full control permissions in the web app and also did that for the Windows service in the server, I restarted the service in Windows Server, restarted the service in Central Admin, everytime checking to see if the Activate btn will enable, but nothing helped. It is still greyed out and I can not enable my solution. – MLC Dec 6 '18 at 15:57
  • I even logged in with the system account in the solution gallery and with my admin account. Either way that option to Activate the solution keeps been disabled. Any other suggestion that might help me? – MLC Dec 6 '18 at 15:58
  • 1
    The Activate btn is enabled now and I tested with 3 browsers (IE, Chrome and Edge) and found that the issue is that as I am modifying an existing .wsp that is active as a solution in the site collection and saving as a template with a different name, when I download from my test farm to prod it is keeping the same solution id, so the issue is that I am having now 2 solutions, the original one and the modified one, both with the same solution id and that is why I can not see the activate btn enabled as the system thinks that it is the original one that is already activated. – MLC Dec 7 '18 at 15:44

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.