2

Hi I have SharePoint 2016 server farm, and from the application server which running central administration service and user profile service running in another app,wfe servers.

The Execute method of job definition Microsoft.Office.Server.UserProfiles.FeedCacheRepopulationJob (ID c1835671-c88c-4821-bf32-7d0d639c714b) threw an exception. More information is included below.

Unexpected exception in FeedCacheService.IsRepopulationNeeded: Failed to Decrypt data...

The Execute method of job definition Microsoft.Office.Server.UserProfiles.LMTRepopulationJob (ID 6318bf99-45ef-425c-9c9b-61d50fdce0d8) threw an exception. More information is included below.

Unexpected exception in FeedCacheService.IsRepopulationNeeded: Failed to Decrypt data...

  • 1
    Hi, as a first step, can you clear the configuration cache and check again ? – Jan Dec 4 '18 at 8:38
  • Hi did it but the same error came – adilahmed Dec 5 '18 at 16:07
3
  1. Go to Central Administration->Application Management->Manage services on server->select your search server in Server section located in the top-right corner. Check if there is Distributed cache service, if so, stop it.

  2. Try to increase the timeout for the LMTCache and DistributedActivityFeedCache using PowerShell command below:

$lmtcache = Get-SPDistributedCacheClientSetting -ContainerType DistributedActivityFeedLMTCache

$lmtcache.RequestTimeout="10000" Set-SPDistributedCacheClientSetting -ContainerType DistributedActivityFeedLMTCache $lmtcache

$feedcache = get-SPDistributedCacheClientSetting -containertype DistributedActivityFeedCache

$feedcache.RequestTimeout="10000"

Set-SPDistributedCacheClientSetting -ContainerType DistributedActivityFeedCache $feedcache

Then use the following command to populate the cache quickly:

Update-SPRepopulateMicroblogLMTCache -ProfileServiceApplicationProxy <SPServiceApplicationProxyPipeBind> [-AssignmentCollection <SPAssignmentCollection>]

Update-SPRepopulateMicroblogFeedCache -[AccountName <AccountName>] -ProfileServiceApplicationProxy <SPServiceApplicationProxyPipeBind> [-AssignmentCollection <SPAssignmentCollection>] [-SiteSubscription <SPSiteSubscriptionPipeBind>]-[SiteUrl <SiteURL>]

Reference: User Profile Server Application - Jobs fail

  • Hi i get below error when i run last command – adilahmed Dec 5 '18 at 16:54
  • I have 2 WFE ;2 APP servers , User Profile Service running in all servers , and Search Host Controller Service ,Search Query and Site Settings Service running in app servers, may running user profile service has make me this issue? – adilahmed Dec 5 '18 at 16:56
  • Make sure you have access – Benny Skogberg Dec 5 '18 at 17:01
1

this type of error occurred when one of the server is unable to decrypt the Key associated with farm.

This key has two pairs, one stored in the registry (after you add a SharePoint server to the farm) while the other piece is stored in the Config db. more details here:

If possible to remove the server from farm and re add it and see it that fix the issue.

  • I did that i remover server and joined again in farm – adilahmed Dec 5 '18 at 19:22
  • is it fixed or still same issue? DC is not running on that server right? – Waqas Sarwar MVP Dec 5 '18 at 19:24
  • Problem still there; DC is running in WFE serves; is good practice to run DC and user profile in same server? – adilahmed Dec 5 '18 at 19:33
  • Is UPA service is running on the App server? Yes it is recommended approach to run DC and UPA on same server – Waqas Sarwar MVP Dec 5 '18 at 19:35
  • yes User profile service running in app servers also and when i run below commadn there is access denied error – adilahmed Dec 5 '18 at 19:37

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.