2

I've been working on an Infopath 2013 form (published to a SharePoint 2013 form library) over the past few weeks. Until recently, I haven't had any issues. Yesterday, I opened the form and it had reverted to a much earlier version (lets call it VBroken).

Since then, I've tried making changes to the form and publishing them. However, after I reopen the form, the form is reverted to version VBroken. The weird thing is that not everything is broken. I can still make text changes or add Data connections. Both of those are saved.

I cannot make property changes or add/remove rules and make those changes stick. Every time I publish, those property changes (like making a section optional) or adding a rule, ends up disappearing.

I've tried publishing to a different site and form library. I've had someone else open up the form using their version of Infopath. The form is still reverted back to VBroken.

Has anyone else seen this issue? Is there any way to fix it besides re-writing the form?

  • When you open the form, are you opening an existing form in the library or a new one? – A.k.A. Fritz Dec 2 '18 at 1:52
  • I am opening an existing form by either 1 of 2 ways: * From Library->Settings->Advanced Settings and clicking on EDIT TEMPLATE * Saving the template on my desktop, closing InfoPath designer, then opening the saved .xsn from my desktop. In either case, it always opens the version that is broken. Any changes I make (whether I publish to the library or save the changes to my desktop), the old broken version shows up after reopening the form. – JustAnotherDev Dec 2 '18 at 21:22
  • Is this form library configured to allow management of content types? You would be able to tell this by going to Library settings —> Advanced settings. It is the first setting on that page. Is it set to yes or no? – A.k.A. Fritz Dec 4 '18 at 0:20
  • No, there is no management of content type. It is a default form library. I went ahead and redid the form from scratch. So far not seeing any issues. It would be great to know what happened, but so far I am chalking this up to the form somehow getting corrupted. – JustAnotherDev Dec 4 '18 at 18:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.