2

I'm getting the message "The blob cache is not enabled in this web application. Image renditions will not be generated until the blob cache is enabled" in image renditions.

Blob cache is enabled in web.config for the web application. How can I fix this error?

2

Couple of things to make sure:

  • make sure you made the changes on the all the WFE, amend the web.config of same web application on all WFE servers.
  • also make sure when you edit the web.config file, enabled="true" something like this:

    BlobCache location="C:\BlobCache\14" path="\.(gif|jpg|jpeg|jpe|jfif|bmp|dib|tif|tiff|themedbmp|themedcss|themedgif|themedjpg|themedpng|ico|png|wdp|hdp|css|js|asf|avi|flv|m4v|mov|mp3|mp4|mpeg|mpg|rm|rmvb|wma|wmv|ogg|ogv|oga|webm|xap)$" maxSize="10" imageRenditionMaxSourcePixels="100000000" **enabled="true"** 
    

Configure BLOB cache settings

  • There's only one WFE. enabled="true" is set in web.config. – jlai79 Nov 27 '18 at 13:36
  • please make sure you are editing the correct web.config...sometime we mistakenly change different web application, as all in the same folder – Waqas Sarwar MVP Nov 27 '18 at 13:37
  • also check this one and verfiy your steps: sureshpydi.blogspot.com/2013/05/… – Waqas Sarwar MVP Nov 27 '18 at 13:45
  • I just found out that my IIS site was stopped. After restart the blob cache was working again. – jlai79 Nov 28 '18 at 8:04
0

Refer to the following article to enable Blob cache step by step:

http://sureshpydi.blogspot.com/2013/05/sharepoint-2013-blob-cache-is-not.html

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.