2

I have created couple of site columns using PowerShell (CSOM) script in SP online site. I have added all these columns to libraries using PowerShell (CSOM). Later I have migrated hundreds of documents to different libraries which contains these site columns.

I want to implement search refiners. So I wanted to add few of the created site columns to RefinableString properties. When I am trying to add the crawled properties to the Refinablestrings, I am not able to identify crawled properties for created site columns.

I have created site columns two days before and migrated data 24hrs ago. I think this time is sufficient for crawling.

Am I doing something wrong here?

1

If these are Modern Team sites, this is a known bug. Not only do you need to add the column to a List/Library and populate that column with a value on a single List Item/Document, you must also add a user to a SharePoint group. At that point, perform a reindex on the List/Library or Site.

See Crawled Properties Not Created From Site Columns in Modern Sites.

  • To appear site columns under crawled properties, no need to attach them to a content type right! – Mihir Nov 22 '18 at 13:54
  • That would be correct – Trevor Seward Nov 22 '18 at 13:55
0

I'd wait a bit longer. It's not unusual for crawled properties to not populate within 24 hours, and only columns that contain data will be indexed, so your empty site columns would not have gotten indexed.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.