1

on Enterprise wiki pages, there is an additional link available, above the site Content:

"[Edit this page]"

When using the above mentioned link, the following error will Show up in a Dialog window:

"You have not checked out this page. Click OK to checkout and edit this page."

Once clicked "OK" (The only available button) the page is checked-out.

However when using the "edit" link on the top right menu, this message is not shown, the page is automatically checked out.

Is it possible to supress this message, as it has no use at all? Maybe using a custom page layout?

Edit: I need the chexk out before edit option enabled. I just want to mimic the behaviour of the normal "edit" button for the "edit this page" button, as the "edit" button does not display this error, but checks out the page automatically.

Following set-up:

  • We are using SharePoint Server On Premise 2016.
  • Publishing Features turned on.
  • Check-out is required for editing.
0
  1. Go to the library you plan to work in.

  2. Click Library Settings.

  3. Under General Settings, click Versioning settings.

  4. In the Require Check Out section, under Require documents to be checked out before they can be edited?, click No.

enter image description here

  1. Click OK to save your settings and return to the Library Settings page.

Note : By doing this changes we can directly edit the pages without check out. If we need to check out pages then we have to go to library and check out the page manually.

  • Thanks for the answer. However this is not what I am trying to achieve. It is absolutely necessary to check out the page before editing. I simply want to mimic the behaviour of the "edit" button on the top right menu for the "edit this page" button displayed just above the page content. – Nik G Nov 20 '18 at 16:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.