0

So I think the question pretty much covers it, I have a number of columns in a sharepoint 365 list which are searchable, results appear for items already created before the crawled property was mapped to the managed property however anything new then does not appear in the search. For example I have job 1,2 and 3, with jobs 1 and 2 being created before the mapping and they appear in the search. I then create job 3 and it will not appear in the search regardless of time passed. Any help would be much appreciated.

  • Can you Re index the list? The new managed properties will appear in search result after full crawl or you can re index the list. – Shashank Nov 19 '18 at 3:17
  • Hi, Thanks for the reply. I have reindexed the list and then waited a day or so with no success unfortunately. I am assuming a full crawl has been done in the background at some point as the data has been there for at least 5 days now but it still doesn't show. – Eddy Chadwick Nov 19 '18 at 22:20
  • Go into your library/list advanced properties and click Reindex. It will mark the library/list as dirty and do a full crawl. Managed properties will only be picked up after a full crawl. – Martin Muldoon Nov 20 '18 at 12:35
  • Hi, Thanks for the reply. So based on that would I need to do a reindex everytime a new item is added to the list? – Eddy Chadwick Nov 20 '18 at 13:22
0

Does it a site column or just list column?

What is the type of the column?

Make sure the managed property is searchable. enter image description here

And the crawled property is Include in full-text index. enter image description here

  • Hi, Thanks for the reply. Yes both of those options are selected. I actually have a few columns this is happening on, one is a calculated column that contains letters and numbers in the format "xxx-000" for example and the other column is just a single line of text. I just cant understand why it is happening. If I remove the mapping and readd it then it picks up the new entries but any created after that would again not appear in search results. – Eddy Chadwick Nov 20 '18 at 11:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.