2

This is in a SharePoint 2016 MinRole Farm (1 Front-End with Dist Cache and 1 Application with Search).

On WFE server I see Error on Event Viewer from 5 AM to 6 PM hourly:

Event ID 8313 User: DOMAIN\Pool - A failure was reported when trying to invoke a service application: EndpointFailure
Process Name: w3wp
Process ID: 1400
AppDomain Name: /LM/W3SVC/########/ROOT-1-###########
AppDomain ID: 2
Service Application Uri: urn:schemas-microsoft-com:sharepoint:service:0f11b87f6c7b45bf8ed09e5ede533b44#authority=urn:uuid:b10dabc24c664df1805a96c4d49ae4c7&authority=https://AppServer:32844/Topology/topology.svc
Active Endpoints: 1
Failed Endpoints:1
Affected Endpoint: http://WFEServer:32843/0f11b87f6c7b45bf8ed09e5ede533b44/MetadataWebService.svc

When I click on the Affected EndPoint URL it shows the Service page, which means the Endpoint is working properly as this reference link explains.

I have no failing jobs and have been researching but don't find any answer to this Error. I did look at several questions that are posted already in stack-exchange related to EndPoint Failure. I have a test environment and I don't have this error showing up in Event Viewer, so this is only happening in this production farm.

Any idea about how to stop this error flooding Event Viewer?

3

We had the same kind of problem in one of the farm. What we did:

  • Stop the MMS service on the effected server (wfe) ( from central admin > system settings > manage services on server)
  • Check IIS and make sure their is no app pool and Site enter for MMS ( under the Services WebSite). if any entry exist for Managed Meta data service, please delete it.
  • If not then start the MMS service on the server ( from central admin > system settings > manage services on server)

On a side note, sometime IIS reset clear that corruption as well.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.