1

What is condition for disabling/enabling "Share With" button on ribbon for lists/libraries?

When I create custom list and select any item, the button is grayed out. enter image description here

When I create document library and select any item, button is enabled and it works correctly. enter image description here

So it means that for lists it's not working, but there is MicroFeed list and when I select any item the "Share with" is enabled and working in the same way as in Document Library. enter image description here

Any ideas?

0

this functionality not available in the classic sites. If you have the SharePoint online site you can share the list items with others or if you have modern team site in SharePoint 2019 then you can share a list item with others. I performed the test in various farm and here are the results:

  • In SharePoint 2019 (Classic SharePoint): when i click on list item and in ribbon i can see Shared With option.enter image description here
  • In SharePoint 2019 (Modern SharePoint): enter image description here

    • In SharePoint 2016, no sharing for list items but for list.

    • IN SPO, you can share the list item same way as SharePoint 2019:enter image description here

Please read the following post to understand it: Share a list item in SharePoint Online

and How to enable Item Level Permissions in SharePoint

  • Thanks for your time spent on investigation. This is a little bit confusing to be honest. So for custom list on SP2016 there is no way to get "Shared With" enabled on ribbon? I've checked on SP2013 and it is enabled, you sent screenshot on SP2019 it is enabled too. So it's SP2016 issue? – Blu3 Nov 8 '18 at 14:32
  • are you sure it is available for SharePoint 2013? Item level sharing what i believe not available for list item level. – Waqas Sarwar MVP Nov 8 '18 at 14:41
  • check this question, he is talking sp 2013: sharepoint.stackexchange.com/questions/103305/… – Waqas Sarwar MVP Nov 8 '18 at 14:43
  • Yes it is enabled but it only shows list of accounts and "Advanced" link. – Blu3 Nov 8 '18 at 14:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.