2

I have a massive 2013 list workflow build to handle projects on the SP Online platform. This workflow utilises a few lookup columns and people fields - but no more than 5!

For some strange reason I simply cannot see on of the lookup fields I have created recently. It simple isn't in the "Current item" list of fields.

Any idea what has gone wrong, and even better how to fix it?

Edited: I testet just for the fun of it if a new lookup column would show up. It seems lookup to other lists works perfectly fine, but lookup to the same list is not present. Is that really by design?

It's NOT an option to rebuild the workflow from scratch, neither is it an option to create a new lookup and delete the old one!

  • Is this a list workflow or a content-type workflow? 2010 or 2013? Nintex? – Alex Filipovici Nov 8 '18 at 7:46
  • It's a normal 2013 list workflow, no 3rd party stuff going on. – Morten K Nov 8 '18 at 7:51
  • For now I'v used the REST api to fetch the lookup element, but it really feels like crossing to river to get water... – Morten K Nov 8 '18 at 17:06
0

Refresh your designer and wait for a while, then check if you can find the new created lookup column.

enter image description here

Besides, try clearing SharePoint Designer cache and re-open it, see if it works.

  1. Close SharePoint Designer 2013;
  2. Delete all the files from location: %USERPROFILE%\AppData\Local\Microsoft\WebsiteCache;
  3. Delete all the files from location: %APPDATA%\Microsoft\Web Server Extensions\Cache.

How to clear SharePoint Designer 2010/2013 cache:

https://social.technet.microsoft.com/wiki/contents/articles/33469.how-to-clear-your-sharepoint-designer-20102013-cache.aspx

  • The field was added a few days ago. Shouldn't have to wait that long :) – Morten K Nov 8 '18 at 9:57
  • Have your refreshed the designer after creating the field in the list? – JoannaW_MSFT Nov 8 '18 at 9:58
  • Yes my computer isn't running for several days without a reboot. I have closed and opned the designer several times since the field was added. Out of curiosity are you able to access a lookup field on a list which looks op upon the list itself? – Morten K Nov 8 '18 at 10:00
  • Per my testing, the new created lookup column will display in the workflow after refreshing the designer. Can you try to clear the designer cache? Check if the issue occurs because the cache. – JoannaW_MSFT Nov 8 '18 at 10:06
  • Other lookup works as well - have you tried with a lookup that targets the list itself? – Morten K Nov 8 '18 at 10:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.