0

I used pageviewer webpart. When I try clicking on the video link, I get this error: This content can’t be shown in a frame There is supposed to be some content here, but the publisher doesn’t allow it to be displayed in a frame. This is to help protect the security of any information you might enter into this site.

How do I fix this?

The code I have is this:

enter image description here

0

You need to Permit iframes from any external domain into pages on this site as the following:

  • Go to Site Collection Settings > Site Collection Administration > HTML Field Security
  • Check Permit contributors to insert iframes from any external domain into pages on this site.

enter image description here

  • Go back to your page and check if the Page URL has been rendered inside the Page Viewer web part or not!

Note: If the issue still persists that means the publisher of this content does not allow it to be displayed in a frame.

  • I don't see site collection admin. I don't have the right privileges for it. Is there any other way to fix it ? – user10 Nov 6 '18 at 13:25
0

The owner of the "framed" content has added JavaScript to detect it is being loaded in a frame. You may need to add a link that when clicked opens their content in a new window or tab. They probably have some code like this in their page:

if (window.self !== window.top) {   error messages here   }
  • I have added the code to the questions. Do you think it is because of the code I have attached? – user10 Nov 6 '18 at 13:24
0

Create a pop up window to see the video :) in that way it does not follow the resctrictions from sharepoint. It use basic html javascript basis :)

  • I have a video slider, would the pop up work for that too – user10 Nov 6 '18 at 15:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.