0

I need my SharePoint extension (.sppkg) that runs in New Experience mode to be available for external SharePoint users. Is it possible to achieve?

1

This often happens when external users dont have access to the app catalog site collection.

This also happens when you make use of the asset packaging capabilities of SPFx which store the files necessary for SPFx extension in the Tenant App Catalog. Now, usually external users dont have read access to the tenant app catalog.

So, you need to add Everyone group to your App Catalog site and provide them with read permission by adding them in the Visitor group.

Also, if you cant see the people picker resolve the Everyone claim, mostly likely it has been disabled at the tenant level.

You can enable it by running the below command and then add the Everyone group to your app catalog. You might need to wait for a few mins after executing this command :

Set-SPOTenant -ShowEveryoneClaim $true

Alternatively, you can store the files necessary for SPFx extensions in an external location like Azure CDN or a document library which is accessible to everyone over the internet. This will ensure that the extension is loaded for External users as well.

Additional reading - How to grant the Everyone claim to external users in Office 365

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.