2

I have created a new List and added two content types in the list.

When I am creating a new item through "modern view", newly added item is getting created with only one content type even though I am choosing different content types.

Through classic view, items are getting added normally.

How can I fix this in "Modern view"?

Thanks in advance.

Additionally added a screenshot:

My content types have different fields.

I tried to add 2 items with different content types by using "modern view". On screenshot we seeing one content type and attention "Required information" in one of the field.

enter image description here

0
  1. To select new content type every time when you are adding new item click on + New. It will show you all the content types enabled on list. Select the content type you want to and add the new item.

  2. In your case, I think the new items are getting created in list with the content type you are selecting. But, you are not having the columns from that content type in your current list view.

  3. To check this, create new list view for your content type and select the columns you are using for that content type. Here you will see newly created item and fields you set.

  4. In SharePoint, even though you are creating new item with different content types, the newly added item will have all the fields from all content types(which you can edit by switching the content type from Edit form).

To create new list view, follow the steps given in following link:

  1. Create, change, or delete a view of a list or library.
  • Hello. Thx.I added new info with screenshot. I have different fields in content type. When I choose Add second Content type - I see fields for this field. Then when I save form and see item with first content type without required fields. – Daniel N. Oct 30 '18 at 7:55
  • In which content type are you having the required fields? – Ganesh Sanap Oct 30 '18 at 8:10
  • In both. 1st content type name "Продукт" and required field "Критерии продукта". 2 content type name "Процесс" and required field "Критерии процесса". 1 content type item created normaly. 2 content type - creating form looks normaly (whith its required fields). But when item created, its with wrong content type (1 ct) and filled field from 2 ct. – Daniel N. Oct 30 '18 at 10:41
0

In my case:

  1. I've created 2 empty Content Types with names I needed and "Item" parent Content Type to site collection.
  2. Then I've added 2 new Content Types with parents from Site Collection Content Types from p.1 to my List
  3. I've added all List Fields that I needed to those Content Types.

This did the job for me. I don't know how and why.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.