0

Our SharePoint Server is build in one box. (SQL and SharePoint)

We encountered 500 internal server error on all the other site collections that was created. Even newly created Web Applications are having the same issue (we created a new web application to test if we can have an up and running SharePoint site - but no. Problem is still there).

All Application Pools are running (started) with no login issue.

Looking at the ULS, we have encountered the following Critical and High Levels logs:

  1. Unknown SQL Exception 1346 occurred. Additional error information from SQL Server is included below. A transport-level error has occurred when sending the request to the server

  2. SqlCommand: 'proc_FetchDocForHttpGet' CommandType: StoredProcedure CommandTimedout: 0 Parameter: '@RETURN_VALUE' Type: Int Size: 0...

Error occurred right after a reboot of the server.

  • What version of the Sharepoint you are running? At first I would try to run PSConfig to see does it resolve the issue. – Marek Sarad Oct 23 '18 at 7:34
  • This is SharePoint Foundation 2013. – Denisse Oct 25 '18 at 4:06
0

This is a connectivity issue . Are you using High Availability in SQL ?

Asking this because you mentioned that you rebooted the server.

0

Have you disabled the Windows Server Loopback Check?

https://blogs.technet.microsoft.com/sharepoint_foxhole/2010/06/21/disableloopbackcheck-lets-do-it-the-right-way/

Windows Server 2003 SP1 introduced a loopback security check. This feature is obviously also present in Windows Server 2008. The feature prevents access to a web application using a fully qualified domain name (FQDN) if an attempt to access it takes place from a machine that hosts that application. The end result is a 401.1 Access Denied from the web server and a logon failure in the event log.

I realise this is a different error message, but it's worth a look!

  1. Open Registry and nav to HKEY_LM\system\CCS\Services\Lanmanserver\param
  2. Create a dword called DisableStrictNameChecking.
  3. Add a value of 1 to this new entry
  4. Exit Registry and reboot your box
  5. Reopen Registry and nav to HKEY_LM\System\CCS\Control\LSA\MSV1.0
  6. Create a REG_MULTI_SZ called BackConnectionHostNames
  7. In the new registry entry, add your FQDN hostnames for your servers.

I hope this helps!

0

We were able to apply a workaround on the issue using the Farm account as an application pool service account - which is not advisable due to security reasons.

Now we are unable to pin point why the Application pool service account suddenly is not working.

-- any clarifications on that would greatly help though.

Like what happened to the app pool service account for it to not work?

by the way, there was a patch applied to the server before everything happened.

  • Security Update KB4462929
  • Security Update KB4462949
  • Security Update KB4462931
  • I had similar situation in the past. The info about the App Pool account got somehow corrupted. Try to update the password of the account and then update the values in you SP Manged Accounts. – Marek Sarad Oct 25 '18 at 7:35
  • @MarekSarad update the password meaning change it? or just re-apply the password on the IIS? – Denisse Oct 25 '18 at 23:47
  • Change it but not update through the IIS but through the Central Administration Managed Accounts. – Marek Sarad Oct 26 '18 at 8:41
  • @MarekSarad would you know why it suddenly didn't work? – Denisse Oct 29 '18 at 23:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.