0

Before I expose my problem, bear in mind:

  • I have full control of my SharePoint 2016 Online collection site.
  • I have a list with content types enabled. Allow management of content types
  • My 2 content types have a long list of columns (#1 = 111, #2 = 113 exactly).
  • I have a default content type for a new form, while the other is not allowed on a new form. Content types configuration
  • The default edit form hasn't been tampered with.

My problem: when I want to edit an item, only one content type is shown (#1). Just one content type is shown

Why can't I choose #2? And most importantly, how to fix it?

I did some search (Google and StackExchange) without any luck. Am I the only one this kind of thing happens? To my future savior, I will eternally be grateful.

Thanks to both of you, it addresses my "Edit" problem. However, when ones click on the "New" button, both Content types appears, which is somewhat confusing: Content types appears in drop down list when pressing on New button

I hope in the future Microsoft will give the opportunity to have content types visible only when editing an item.

  • Have you checked that In "Change new button order and default content type" settings, both the content types are checked(Visible)?? – Ganesh Sanap Oct 23 '18 at 3:02
  • I think you are not using Document Sets, but if the content type is not added to the Document Set, it will not appear. I thought I would mention it, though it does not sound like it is your issue. – Tally Oct 23 '18 at 10:52
1

First of all check the "Change new button order and default content type" settings.

To use the content type while editing the item, the corresponding content type should be checked(Visible).

So in your case, please make the content type (which is not allowed on new form) as visible.

  • I hate the fact this column is visible when someone click on "New" item. Seems I don't have the choice... – The girl with red hair Oct 24 '18 at 2:18
2

Yes apparently this is how it works. If you uncheck the visibility of the CT from the "New" button order menu in the list settings, it disappears from the default edit form as well. I have tried this in a classic library view and the behavior is the same. In classic view the content type drop down gets hidden.

Also tried setting the content type of the item to the this new button hidden content type using PnP-PowerShell. The next time you edit that item in the editform, the fields from that other content type shows in the edit form, but the content type is not set. So looks like, it becomes unusable

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.