0

I have a SharePoint 2013 workflow. Whenever the workflow is triggered or started manually, it's Internal status is "Not started".

I have tried to write a simple workflow just to log and send email but the status of workflow remains same.

I tried to terminate the workflow but the page refreshes and nothing happens. Ultimately, it's still on "Not started" started.

The following troubleshooting has been done:

  • I have synchronize the USP, associated app pool is started, USP and USP synchronization service started.
  • Workflow manager Farm status: Running
  • Service Bus Farm status: Running
  • Workflow management site running
  • Executed "iisreset" on the server.

Any help is much appreciated!

  • 1
    Have the workflows been working at any point or is it new set up of the WF2013 manger. What version of Sharepoint are you using? – Marek Sarad Oct 23 '18 at 7:39
  • It sounds like it could it be a field issue? The error messages in workflows are usually pretty unhelpful. Perhaps try swapping the name field used in the workflow - or checking the way the Name field you are using in your workflow is configured to allow it to be used as an email recipient. I seem to remember there are multiple types of Name field around, some 'for use in forms' etc – Tally Oct 23 '18 at 13:34
  • @Tally There are no error messages as the workflow is stuck at "Not started", the workflow is not even starting. However, i tried to create a new workflow that only logs and send email (hardcoded user), but it's still stuck at "Not started". – Sohail Shaikh Oct 26 '18 at 4:28
  • @MarekSarad Earlier, the workflows were cancelled when started, so I troubleshooted and found that USP was not configured properly so I re-created the USP. Due to this, the workflow started running but didn't send email (HTTP 500 internal error). To troubleshoot this, I re-registered the Workflow service proxy, restarted the services and all of a sudden workflow stuck at "Not started". Later I applied CU2 update but the issue still persist. – Sohail Shaikh Oct 26 '18 at 4:35
  • What update version of SP you are? The latest CU for WFM is CU5 : support.microsoft.com/en-us/help/4055730/… – Marek Sarad Oct 26 '18 at 8:46
1

This can be a timer job issue. Can you do this ?

Open Run ---> Type services.msc .

Go ahead and stop the SharePoint timer service from "services.msc" .

On the right click of SharePoint timer service ,configure the start up type to automatic.

Go to Task manager and kill all the processes with name "SharePoint Timer Service".

Restart the SharePoint timer service from services.msc .

If this does not solve your problem let me know.

  • This does not solve the issue as well. – Sohail Shaikh Oct 25 '18 at 9:21
0

Have you installed recent .NET security updates.

The September 2018 .NET Security updates caused workflows to stop running. To fix, you have to add additional lines to the SharePoint web.config file.

See this KB article at MS:

https://support.microsoft.com/en-us/help/4465015/sharepoint-workflows-stop-after-cve-2018-8421-security-update

This blog at MS has a link to a PowerShell script that will make the necessary modifications to web.config for you:

https://blogs.msdn.microsoft.com/rodneyviana/2018/09/13/after-installing-net-security-patches-to-address-cve-2018-8421-sharepoint-workflows-stop-working/

  • But these changes were required if you were using "If" conditions in the workflow and there is no conditions in my workflow. – Sohail Shaikh Oct 22 '18 at 19:13
  • Where does anything mention that this applies only to workflows that have "if" conditions? Quoting from the blog post "After applying .NET Security Only patch to resolve CVE-2018-8421 (Remote Code Execution Vulnerability) , all SharePoint out of the box Workflows fail to execute and the log will show an error like this:" @SohailShaikh – teylyn Oct 22 '18 at 20:41
  • Correct, it was also determined that this not only affected “out of the box” workflows, but also any SharePoint Designer-created workflows, and even Nintex workflows I think. – mannaggia Oct 22 '18 at 20:52
  • @mannaggia If that's the case, even 2010 workflow should not work, but on the same site collection, 2010 workflows are working fine. – Sohail Shaikh Oct 23 '18 at 4:49
  • @mannaggia Even after including the assemblies, it does not fix because 2010 workflows already working fine. – Sohail Shaikh Oct 23 '18 at 7:19
0

This is not the best answer(solution) but uninstalling the workflow manager and then re-installing (& configuring) made the workflow run.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.