0

Scenario

An employee navigates to a document library that requires documents to be checked on our SharePoint 2016 on-premises environment. They then edit an Excel file (e.g. by right-clicking on the document name and choosing "Open in Excel"), which checks out the file and opens it in the Excel client application. So far, so good.

Within 7-10 minutes, a yellow bar appears at the top of the Excel window indicating that the document needs to be checked out before it can be edited. (Note that the document is still checked out to the user on SharePoint.)

If the user clicks the button on the yellow bar to check out the file, they get an error message indicating that the file is locked for editing (by the very same user).

Workarounds

We have a few workarounds, but we're still at a loss as to why this suddenly started happening.

  • Save the file locally, work on it, then re-upload the file
  • Ignore the yellow bar in Excel (don't click the button initially), but go back to SharePoint in the browser and discard your own check out, then go back into Excel and click the "Check out" button on the yellow bar; repeat this every ten minutes whenever the yellow bar appears
  • Use the Excel web application (via Office Online Server) to edit the file instead of the client application
  • Configure the library so that checking out documents is not required

The workarounds all have significant drawbacks so I'd like to identify a real solution.

Troubleshooting steps performed

I've tried a number of things with no luck so far.

  • Repaired Office, rebooted
  • Uninstalled Office, rebooted, reinstalled Office, rebooted
  • Downgraded to an earlier version of Office via the command line cd %programfiles%\Common Files\Microsoft Shared\ClickToRun followed by officec2rclient.exe /update user updatetoversion=16.0.9226.2156 and rebooted
  • Cleared the Office cache both through the Office Upload Center and by deleting files out of the OfficeFileCache folders located at Users/[user]/AppData/Local/Microsoft/Office/15.0 and 16.0
  • In Excel Save Options (File -> Options -> Save) toggled off the "AutoSave OneDrive and SharePoint Online files by default on Excel" and "Save AutoRecover information every 10 minutes" options
  • In SharePoint, changed "Allow items from this document library to be downloaded to offline clients?" to "No" (in Library Settings -> Advanced Settings -> Offline Client Availability)
  • Ensured that the root site URL of the SharePoint web application that contains the document library has been added to the Trusted Locations section in the Trust Center (Excel File -> Options -> Trust Center -> Trusted Locations)
  • Removed generic Office credentials from the Credential Manager on the PC

Additional Info

The problem happens for users on both Windows 7 or Windows 10.

The Office version is Office 365 Pro Plus, build 16.0.10827.20150 (from October 9th, 2018).

The SharePoint environment is SharePoint Server 2016 (on premises) using HTTPS and Kerberos with Active Directory for authentication.

0

We tracked the problem down to the times on our web front end servers being incorrect/out of sync.

Correcting the server times resolved the issue. We set them to synchronize from the primary domain controller, as documented here: https://docs.microsoft.com/en-us/windows-server/networking/windows-time-service/windows-time-service-tools-and-settings

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.