0

We are unable to open some .docx documents in Word desktop application from an on premise SharePoint 2016 document library. There are at least 2 of such documents, but might be more.

The error message in Word is:

Sorry, we couldn't open http://filepath

The file opens in Word Online, but only in read mode - if I try to switch to Edit mode, there's an error.

It works perfectly fine if I just download it and open in Word. Many (possibly All) users are affected.

What I already tried:

  • Deleting OfficeFileCache
  • Opening from different browsers
  • Opening directly from Word (file->open)
  • Uploading a new version of the file (download->edit->upload)
  • Opening the file from a server where an older version of Word 2016 is installed
  • Running full crawl, reindexing the library

-If I download the file and then upload it with a different name - it opens fine. But that's not a solution because we need version number and version history.
-If I download the file, delete the original from sharepoint and upload it with the same name - it won't open

Our Word version is 1809 (O365)

Would you see any other solutions? Thanks!

  • Have you tried this? 1. Delete from site, 2. Delete from the recycle bin 3. Only after removing from bin try to upload the file. – Marek Sarad Oct 17 '18 at 12:34
  • That way we lose the versioning, which we can't afford. – xmihu Oct 17 '18 at 14:18
  • I think in this case you need to open support case with MS. – Marek Sarad Oct 18 '18 at 11:37
0

I managed to resolve the issue, below is what I did in case someone has the same problem. However I am not sure if all steps were needed:)

  1. I moved the documents to a new folder inside the document library from Site Settings-> Content and Structure

    That way they could be opened. But if I moved them back, they did not work again, like the link was broken.

  2. Temporarily left the files in the new folder.

  3. Set the site and library to be reindexed with the next crawl.

  4. Ran full crawl overnight.

  5. Once the crawl was completed I moved the files back to the old location and cleared local office cache. Now both can be opened.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.