2

I've just provisioned the App Management Service Application in my SP 2013 on-prem dev farm. However, the status says "Stopped" when I view the list of Service Applications.

enter image description here

The service instance is started, however.

enter image description here

When I check the service application in Powershell, it says "Disabled".

enter image description here

How can I get the service app and associated proxy to a "Started" status?

Thanks in advance!

1

The Disable status means the App service is not provisioned correctly, so try to provision it using PowerShell

$srv = Get-SPServiceInstance | where-object {$_.TypeName -eq "App Management Service"}
$srv.Provision()
Get-SPServiceInstance | $srv #check its status

This issue might also occur if you have started the App Managment Service in Services on Server before creating the App Managment Service Application Service.

So in your case,

  • Stop the App Managment Service in Services on Server
  • Delete the newly configured App Managment Service Application Service
  • Reconfigure App Managment Service Application Service in Manage Service Application
  • Start the App Managment Service in Services on Server again.

Check also SORRY, SOMETHING WENT WRONG APP MANAGEMENT SHARED SERVICE PROXY IS NOT INSTALLED


  • Thanks, Mohamed. Unfortunately, when I attempt to stop the service, it gets stuck in a 'stopping' status. I've tried restarting the timer service and rebooting the server, but its still stubbornly stuck. – Drew Paxton Oct 12 '18 at 22:42
1

I was able to get this fixed by provisioning the App Management Service Application and App Management Service Application Proxy separately in PowerShell.

enter image description here

enter image description here

  • 1
    Hello @drew, this is what exactly said to you in my answer for the first suggestion! "The Disable status means the App service is not provisioned correctly, so try to provision it using PowerShell – Mohamed El-Qassas MVP Oct 13 '18 at 7:48
  • @MohamedEl-QassasMVP, I didn't mean to slight your answer at all. When I first tried your initial answer (and what ended up working for me), the service was still stuck in a 'Stopping' state. That also made me unable to try your second answer because I couldn't fully stop the service. – Drew Paxton Oct 15 '18 at 15:48
  • Once I deleted the timer job instance that was attempting to stop the service, I was able to restart it. Once the service was in a 'Started' state again, I was able to use a variation of your answer. But if you look at mine, I'm reprovisioning the Service Application and associated Proxy. Not the Service Instance itself. In any case, you definitely pointed me in the right direction, so I've marked your post as the answer. Cheers, -Drew – Drew Paxton Oct 15 '18 at 15:51
  • @Drex No problem bro, glad to hear you have solved your issue! Thanks for your appreciation, Have a nice day! – Mohamed El-Qassas MVP Oct 15 '18 at 15:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.