0

SharePoint 2016 Standard Edition

When I try to upload an document to the document library, it shows "This shouldn't take long" for longtime. Approximately it takes 5 mins to show metadata forms.

Check-in also issue, it shows the following error message after loading longtime, "The server was unable to save the form at this time. Please try again."

Note: Server CPU Utilization and Memory looks fine. I checked in Chrome and IE. All libraries working fine in the same Site Collection other than this. The difference between this library(errored) and other library is, I created overlay in the calendar for this library.

  • Do you have a unique permission in this library? – Mohamed El-Qassas MVP Oct 12 '18 at 17:51
  • Yes. All the libraries in the site having unique permissions. – Xavi Oct 12 '18 at 17:53
0

This issue might occur If the library has unique permissions and a user/group has permissions only on that library and has limited or no access at the site level.

So try to grant this user/group at least read access to the site level to avoid this issue!

For more details check The server was unable to save the form at this time. Please try again

  • No luck. I am the Site collection admin and having Full control permission over the site and libraries. This issue only for two libraries which i created calendar overlay in the Site calendar. And i also checked by removing those overlays still same issue. – Xavi Oct 15 '18 at 16:00
  • More Info: The library which created using that template also same issue. – Xavi Oct 19 '18 at 17:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.