0

We have a strange issue here, looks like nobody, who is not a site collection administrator, can access anything under the collection (classic). The rights are goot distributed, at least, when I click on "check permissions" I can see that user x has read access, that is coming from group visitors. Even giving full control has no effect. Tested with multiple users.

The standard approval process doesn't seem to be working. User goes to link, gets access denied screen, asks for access, I get the mail, click on approve, the user gets confirmation mail, clicks on the link in the mail, and again, get the same access denied screen.

The issue is with only this one site collection. Did anyone see an something like this?

Edit: When I, as site collection administrator visit the /_layouts/15/settings.aspx page, I don't see the "site permissions" or any other access related options. I can access the /_layouts/15/user.aspx page tough.

Edit2: Looks like something is really messed up, we have a subsite that inherits permissions from the top site and our test user can access that one, but not the top site. That is, in theory, not possible. Now discussing with support.

  • Are those users internal or external users? – sssreddy Oct 10 '18 at 19:01
  • They are internal users. – vilmarci Oct 11 '18 at 8:36
0

Can you please try to add any one users through powershell, this kind of issue happening frequently in SharePoint Online but still not able to find the Root cause

Add-SPOUser -Site https://tenant.sharepoint.com/sites -LoginName userID -Group "Visitor Group"

  • Thank you for the idea. Tried, didn't help. Also, added extra info. – vilmarci Oct 11 '18 at 8:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.