1

I have been able to do this with a bit of trial and error but I could do with a bit of clarification before I explain this to anyone in my team as I am still a bit confused !

  1. I have a local repo dir
  2. Both VSCode and Cmder are both opened in this dir
  3. I am connecting to DevOps via a proxy http://myproxy:80
  4. I notice a Personal Access Token with code read/write and read package has been auto created on DevOps and held in the Windows Cred manager
  5. VSCode 1.27.2 + Visual Studio Team Services extension 1.136.0

VSCode => Application Proxy / User settings

Proxy = http://myproxy:80 Proxy strict SLL = false

VSCode Terminal

git config ---global http.proxy 

http://myaccount:mypassword@myproxy:80 <- this seems to be referenced when I sync changes in VS Code

Cmder

git config ---global http.proxy

http://myproxy:80 <- notice the subtle difference!

git config ---list

http.proxy shown as above

The key to getting the sync to work is setting the correct remote.origin.url

remote.origin.url=https://dev.azure.com/<devOpsAcc>/_git/MyProject

When I am asked to run the Command Task. Teams:Times:Signin, I present my own PAT but still asked for a password.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.