1

When sharing with other users, the email notification is sent correctly "Which mean my outgoing SMTP configuration is correct".But, when I assign a task to a user or send an email using a workflow, the email is never sent.

I checked the event logs, nothing is there related to my issue. Just some errors related to the user not having access to the LOGS folder. "Despite the fact that I gave the user full control on the folder".

I also tested my virtual SMTP using PowerShell's "Send-MailMessage" and it works fine.

I tried both the 2010 and 2013 workflow platform. When using 2010, I get a message saying

"The e-mail message cannot be sent. Make sure the outgoing e-mail settings for the server are configured correctly."

When I use the 2013 workflow platform, no error message is shown and the workflow gets completed successfully (without sending the email).

----- EDIT ------

No matter what "From" address I put on the "Outgoing SMTP configuration", the email will always be sent using the email I configured on the virtual SMTP.

The share emails are not sent using the address of the user, the emails are sent using the address on virtual SMTP.

Any help on how to debug this will be appreciated.

  • The user does not need permissions to the drop folder, but one of your service accounts probably does. – Mike Smith - MCT - MVP Oct 7 '18 at 20:43
  • I added permission for "Everyone" on the mailroot folder. Didn't help – Abdulrahman Oct 7 '18 at 21:29
1

Their is a technical difference between Sharing & alerts / workflow emails.

  • Sharing: When sharing emails go out it user the user's account for the sending the email. i.e. If User A is share a document to with user B at that time SharePoint will use User A's address as From address.
  • Alerts / WF email: When SharePoint send outgoing emails on the action of Alerts / WF, it use the From address from the outgoing email Settings ( from central admin, where configured the outgoing (server url, Reply to & from email address etc).

Now couple of things you have to make:

  • From address is valid and has power to send the email.
  • you can test the outgoing email using that from address.
  • Check the outgoing email settings: Central admin > system settings > configure outgoing email make sure configuration are good.
  • Thanks for the valuable info. I have edited my question with some observation based on your answer. – Abdulrahman Oct 7 '18 at 22:38
  • what is your SharePoint version and what is build number? also can you put working email address in virtual smtp server as well as in SharePoint outgoing settings – Waqas Sarwar MVP Oct 7 '18 at 23:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.