0

A customer has migrated from 2007 to 2013, one of their employees did not get their permissions migrated properly, so she could not modify files in a shared library. I gave her contribute permissions and now she gets an error when trying to access the site with the library.

UserProfileApplicationNotAvailableException_Logging :: UserProfileApplicationProxy.GetRawPartitionID has null proxy.

Most solutions online relating to this error talk about the User Profile Service Application not being setup, but that is not the case. No other user has this issue.

1

I would remove the users complety from the site collection and then re add the user and see if that fix the issue.

  • check the current permission of the user ( from the site settings > permission page) and right it down.
  • Now remove the users from all locations
  • Now remove the user from User Information List as well, you can do it by going "https://sitecollectionurl/_layouts/people.aspx?MembershipGroupId=0" and remove the user from site collection.
  • Now re add the user with desired permission and test it.
0

This error usually means the User Profile Service isn't tied to the web application (Central Administration --> Web Application Management --> Service Application Associations), but if it's user specific, is there anything being cached? Clear cookies/cache, and make sure the user has the site in the local intranet zone.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.