1

In SharePoint Online I have a document library with a column "HFMetadataStatus". This column is just a "single line of text" property and has a default value of "unset".
I copied 1000 files in the library and all of them got "HFMetadataStatus = unset" as exspected.

When I used the SharePoint Search with the query "Querytext": "HFMetadataStatus: unset" I got all items of this library as a result.

On the next day I changed the value from "unset" to "Done" on all files.
After one week I searched again for "Querytext": "HFMetadataStatus: unset" and expected to get zero results, because I updated the property.
But unfortunately I still get the exact same result like before my change.
How can this be? Anybody has an idea what might go on here? I added HFMetadataStatus as a managed property of cause, but the index seems not to be updated for any reason.

How can I debug that?

  • What's the crawl schedule for the web applications? – Matthew McDermott Oct 3 '18 at 1:42
  • Crawl schedule? Do I even have access to SPO crawl schedule? – David Mason Oct 4 '18 at 6:29
  • Sorry, didn't notice the SPO reference. Use Kasper's suggestion. – Matthew McDermott Oct 4 '18 at 11:45
2

It might be a good idea to download the Sharepoint search query tool and have a look at the raw values from the query. If it shows the same result I'll say that is likely that the crawler is not working on your tenant and open a support ticket. Btw it is a fact that MS has a major issue with the search engine these day and properties are not crawled(SP148979).Perhaps it could be related to that

  • Yes, I will open a ticket. Probably the best solution. My index is still wrong... – David Mason Oct 4 '18 at 6:29
1

You could try to reindex on that document library

Ribbon Library > Library settings > Advanced Settings > Reindex Document Library

  • 1
    That will not trigger the search engine to start a crawl, but will mark it as dirty for the next time the crawler is running – Kasper Bo Larsen Oct 2 '18 at 15:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.