The OOS providing services to the SP 2016 farm has EditingEnabled:False and I can view in browser .pdf/.doc but I can not view in browser docx/docm/xlsx/pptx as it gives me an error of "Sorry, you don't have a license to edit documents with....". I want the same behavior for these ext as the one for .pdf/.doc, to view in browser. I looked into the wopi-discovery action names for these ext to compare between them to se if I find any difference between .doc and .docx that can light up a way to fix this but I didn't find it. Is there a way to resolve this issue?

2 Answers 2


With '-EditingEnabled:$false' during the configuration of OOS, you need to configure SharePoint licensing to allow users to access the appropriate components of SharePoint, but not allow editing in OOS.

You'll need to use a couple of PowerShell commands to achieve what you want. these are 'New-SPUserLicenseMapping' and 'Add-SPUserLicenseMapping'. To get a list of supported SharePoint user licenses from the SharePoint farm, use 'Get-SPUserLicense'.

The commands to use are:


This returns the list of available user license types. This is usually Enterprise, Standard, Project and OfficeWebAppsEdit.

$lmap = New-SPUserLicenseMapping -SecurityGroup "Domain Users" -License Enterprise

This creates a license mapping object that we'll use in a moment. In this example, I'm allowing all domain users access to the SharePoint Enterprise features, but NOT OfficeWebAppsEdit.

$lmap | Add-SPUserLicenseMapping

This applies the user mapping object to the farm.


This enables user licensing (note that this is a required step and the previous configuration steps won't do anything until this last command is run).

  • Thank you for your answer, but what's the relationship between enforcing an enterprise license for every domain user and the issue that I am having for some of the Office extensions that can not be viewed in browser?
    – MLC
    Sep 25, 2018 at 20:51
  • The error you're getting is that the current user is attempting to open the document concerned in edit mode rather than read-only mode specified by the EditingEnabled:False parameter during OOS configuration. The SharePoint licensing tells SharePoint not to attempt to open the document in edit mode in OOS, but to open it in read-only mode only instead as all domain users (in my example) now do not have a license to edit documents in OOS. Sep 27, 2018 at 15:30
  • Do you know if Microsoft has published any article with all the steps you have to follow when you want to disable editing with OOS in SharePoint 2016?
    – MLC
    Sep 27, 2018 at 17:54
  • In short, no, however when I needed to create the same config for a customer, I put the requirements together from a number of blog posts, including wictorwilen.se/… and sharepointeurope.com/… . The commands that I listed in my answer are the ones we used to configure their farm. Sep 28, 2018 at 11:26
  • It is my understanding that to implement your solution I will need to have "Domain Users" as the only container being synchronized with SharePoint, correct? And also for licensing enforcement I will have to match the # of CALS to the # of users that are in that security group, right?
    – MLC
    Oct 10, 2018 at 14:36

I discovered I was having this issue in a document library but didn't have the issue in the search when returning the same documents as results, so that behavior was only in the document library and I fixed it by going to Library Settings>Advanced Settings and in the section of "Opening Documents in the Browser" the option selected for "Default open behavior for browser-enabled documents" was "Use the server default (Open in the client application)" and I changed it to "Open in the browser". Then click Ok at the bottom to save my changes. After this, all Office extensions are opening in browser by default when you click on the file name.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.