1

10 server farm with 5 WFEs with F5 load balancer.

We want to disable RM on a single WFE to make it a dedicated crawl target. I have found how to disable RM across the whole farm, and how to disable the server from the RM pool, but that seems to only stop other servers from sending requests to that server, not stopping that server from sending out requests to the other WFEs.

So how do you disable RM on a single server so all traffic to that WFE stays on it?

1
  • whats the role of your WFE servers? WFE minrole or custom?
    – Waqas Sarwar MVP
    Sep 25, 2018 at 12:41

1 Answer 1

1

have you tried this powershell, it will disable / unprovision RM service on the server:

$Ser = get-spserviceinstance -Server "your server name"| ? {$_.TypeName -eq "Request Management"}
$ser | Stop-SPServiceInstance

You just need to put your server name their and run it.wait for couple of minute and get the status of the RM (you will see it is online on all except the one you disable).

get-spserviceinstance | ? {$_.TypeName -eq "Request Management"}

Note: this will only work if you have custom minrole, if not then nightly rule will enable it again.

Description of MinRole and associated services in SharePoint Servers 2016

6
  • Will it be reprovisioned every night since its not disabled in CA?
    – Semada
    Sep 25, 2018 at 13:05
  • Whats minrole you have on that server? if you have custom then it will not.
    – Waqas Sarwar MVP
    Sep 25, 2018 at 13:18
  • The minrole is Front-End. So we would have to change the minrole to custom to keep the RM from reprovisioning?
    – Semada
    Sep 25, 2018 at 13:19
  • that is correct, If not then a health rule every night will fix the server as per Minrole and start the instance which should be running.
    – Waqas Sarwar MVP
    Sep 25, 2018 at 13:23
  • Thanks for the info. Does changing the minrole of a server in CA cause any outage on any other server in the farm? Or will it only affect the server you are changing the minrole of?
    – Semada
    Sep 25, 2018 at 16:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.