6

My Spfx spkg uploads successfully to the apps catalog. Tenant wide upload is enabled.

When I do 'Add an App',

This app is not available for installation under 'From your Organisation'

enter image description here

Although when I try to add the web-part on a page, this web-part is available there:

enter image description here

Now I again did some changes to the source code. Updated Spkg file with the new version including the changes done. The web-part is available to be added but the latest changes do not reflect in the web-part.

Any suggestion where I could be going wrong?

  • 1
    Just keep the version number same and upload the app. It should update automatically. Only if you have added a new webpart or extension would you need to change version number. – Gautam Sheth Sep 23 '18 at 9:47
  • @GautamSheth If I will be using the same version number how am I going to differ the different versions for backup in the apps catalog? Also I don't see workbench changes in the web-part deployed in the apps catalog. – mohd tahir Sep 24 '18 at 3:18
4

Realized my mistake, I was directly executing the following command:

gulp package-solution --ship

Then I executed the folowoing set of commands and it worked this time:

gulp clean

gulp bundle --ship

gulp package-solution --ship

More details here

  • 1
    Great @mohd tahir, Please don't forget to accept your answer as accepted to close this thread :) – Mohamed El-Qassas MVP Sep 24 '18 at 7:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.