2

I haven't run into this particular problem before, and it seems rather strange to me.

I'm trying to make some changes to a site. So, I go to Site Settings, of course. From there, under Look and Feel, I click Title, Description, and Logo. Instead of seeing what I expect, however, I get an error page that reads:

"Sorry, something went wrong. A list, survey, discussion board, or document library with the specified title already exists in this Web site. Please choose another title."

This confuses me. I'm trying to access the settings. Any ideas on how to get around this?

2

Actually, It's strange behavior specifically when editing lists Title, Description, and Logo settings, where you can have multiple lists with the same display name without any issue in SharePoint but not recommended from user experience perspectives!

So try to investigate the issue as the following:

  • Try to edit the list title using SharePoint Designer.

    • Open SharePoint Designer, Connect to the site.
    • Go to lists and library, Right click on your list, click list setting.

    enter image description here

    • Chane the list title by providing a new name > Save > browse your list

    enter image description here

Note: This doesn't change the list name, it just change the list title.

  • Now, go back to edit the list title from the browser, and check if you still face the same issue or not.

If the above solution didn't help, so try to do the following:

  • Make sure you didn't have a list with the same title name and try to change it or provide a new one for the current list, check this (Unlogic but may help)

  • Also in this article, it mentioned it may a permission issue.

  • Worth checking, of course. However, it's a subsite name I'm trying to change, not a list or library name. I'm guessing it's a permission issue, as I'm an SA, not an SCA. I appreciate your help and guidance. – DanJ Sep 25 '18 at 14:24
  • 1
    Welcome, @DanJ Yes, I know you need to just change the title, so I recommend to change it with your suitable name using SP designer and check it will be reflected or not! if reflected try now from GUI, also I mentioned one article takes about it may be related to permission issue, hope it help! – Mohamed El-Qassas MVP Sep 26 '18 at 3:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.