1

I created a contribute no delete permission and one checkbox we unchecked was the "Use Remote Interfaces" when unchecked it prevents users from accessing the site. Does anyone know why?

I assigned a group the contribute no delete permissions and included inside the group a AD group, as well as individual users and they are unable to access the site.

2

This could be caused by the fact that the users would no longer have permission to use REST endpoints. There would be pages and web parts inside the site that require access to REST endpoints.

I believe in your case you will likely want to grant this permission.

While on-premises versions of SharePoint you can disable the "Require Use Remote Interfaces Permission" at the web application level, but this has the effect of allowing anonymous users to access some of the REST endpoints.

2

The main use of Use Remote Interfaces is Using SOAP, Web DAV, the Client Object Model, or SharePoint Designer 2013 interfaces to access the website.

In fact, there is a hidden part in this description, where some UI parts in SharePoint uses these interfaces like REST API to can access the site and work properly.

Note: By default, the Use Remote Interfaces is enabled for ALL permission levels. event the minimum permission levels like View Only, Limited Access, Read require Use Remote Interfaces.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.