3

starting last wednesday I lost the ability to save changes I make to my HTML/CSS/JS files in the file editor. They allow me to "Open in Text Editor" but the Save button never appears at the top of the page.

It used to look like this: How the page used to look

Now when I make changes the bar never loads the buttons:enter image description here

I have tried this on different PC's different browsers. This account had design rights and was able to do this before, I have tested by giving it Owner level access but still cannot see the buttons.

Weirdly I CAN see the buttons and save changes when logged in with an admin account which I don't understand because both accounts have the same access to the site [owners] why can't I do it with my regular account?

The only difference I am aware of is that admin account has SharePoint administrator role in azure but why would it require this all of a sudden?

We also tried with a colleagues regular account which is also unable to save changes now.

UPDATE: 04/10/2018 Now I have lost the buttons from the admin account too! So I have to make changes to a local copy then re-upload, this is such a pain!

The problem seems to have happened before: https://techcommunity.microsoft.com/t5/SharePoint/SharePoint-Online-File-Editor-Won-t-Save-Changes/td-p/86303

UPDATE: 11/10/2018 I now have the save / share ect buttons back for all accounts - nothing was done on our end just had to wait for the problem to be fixed

  • from yesterday onwards,am also facing the same issue, on my SPO site / txt, js, html files. – SaMolPP May 17 at 6:04
  • I'm having the same issue with text files on Onedrive. On occasion the menu items reappear. It's driving me crazy as I need to update files while out of the office, so making updates via a web browser is essential to my workflow. There seems to be no answer to this issue, and no support from MS. So currently looking to migrate away from Onedrive over to a more reliable service. – SyntaxGoonoo Jul 15 at 22:39
0

I have been having the same problems. The problem is found only on one site (we have multiple SharePoint sites) and with multiple people no matter their permissions. I have had to make significant changes to my department's SharePoint site and subsite, but I’ve had to take quite the walk around to do it. Here are temporary solutions to edit and save:

  1. If you are wanting to save use the keyboard shortcut (Ctrl + s for PC and command + s for mac). This isn't a real solution because it only works some of the time. Also, before when you would save the file or use this keyboard shortcut it would say saved in the same location as the missing buttons. The only way you can know if the change has been made is to either see if the file (code in my case) actually makes a change on the SharePoint site or by downloading the file to see if it has the changes on your local computer.
  2. Download the file and make changes locally and then load the file back up and replace the old version.

Both of these solutions require more steps that the classic save button, but they at least have been working for me.

If you are wanting to use any of the other missing buttons and not just the save button you are going to find yourself even more in a lurch. If you are able to resolve the problem, please let me know since I am not receiving any support on the issue... when I should have ample support.

Side Note: I have a further issue (only happens to me as far as I can tell) of SharePoint attempting to render (aka display) HTML rather than display it as plain text before opening it up in Text Editor (Only happens with HTML).

  • Initially I tried CTRL S but it didn't seem to save the changes, though I only tried it a couple of times then concluded it was broke. I did begin with downloading the file for local changes then re-uploading but it is a pain especially when i'm just trying to add logging. For some reason my admin account is uneffected so I am able to use this for my changes - I do not think this is a good solution as edits are no longer attributed to a specific person (another person has access to this admin account) - For your HTML issue try adding "&p=5" to the end of the URL I also ran into that – Bsedd Sep 27 '18 at 10:59
  • I still have not reached a satisfactory answer and my problem persists. I have found a better way that is quick and edits remain attributed to a specific person. I dowloaded the who folder of files locally via "sync" which logs all my edits as if I had edited them online. I know this still isn't a full answer but it has improved the time it takes to make eidits. In fact I think it misght even be more convieneient because you can use your prefered IDE and it might even save time because I can use CTRL+S to save. – CHINCHUDO Nov 7 '18 at 1:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.