0

I am using SharePoint 2013 and installed Office Web Apps in a separate server which is not a Domain controller. In my SharePoint site document library i am not able to Edit my Word document. I can view and Edit all other files like Excel,PowerPoint but not Word.I am getting an error that the service is busy. I have referred the below links but nothing worked.

https://sharepointdojo.wordpress.com/tag/word-web-app-cant-open-this-document-because-the-service-is-busy-please-try-again-later/

http://www.spdeveloper.co.in/sharepoint2013/office-web-apps-configuration-issues.aspx

Please suggest

For reference: Getting the below Error

  • You can find logs on your OfficeWebAppsServer by default in C:\ProgramData\Microsoft\OfficeWebApps\Data\Logs\ULS. Look for the "Session ID" and provide those logs for further troubleshooting. – MHeld Sep 21 '18 at 5:30
0

I suggest you remove Office Online server farm from SharePoint and recreate the Office Online server farm from SharePoint.

To remove Office Online server farm from SharePoint and recreate the Office Online server farm from SharePoint, refer to the following steps.

OWA Machine

===============

  1. Take farm offline (if there is a load balancer)

  2. Collect the current Farm information via Powershell (on WAC Server):

    Import-Module -Name OfficeWebApps

    Get-OfficeWebAppsFarm > c:\MyWACfarm.txt

  3. (If multi-server farm) use Powershell (on WAC Servers) to remove each child machine from the farm, then remove the parent machine. This will delete the farm.

    Remove-OfficeWebAppsMachine

  4. Reboot the Office Web Apps server(s).

    5.Recreate the farm via Powershell (on WAC Server) using (if appropriate) the parameter values from "MyWACfarm.txt".

New-OfficeWebAppsFarm -InternalURL "http://WACServer.corp.contoso.com" -AllowHttp -EditingEnabled -OpenFromURLEnabled

SharePoint Side

================

Note: You may want to rebuild the bindings via SharePoint Powershell (on SharePoint Server):

Remove-SPWOPIBinding -All:$true

New-SPWOPIBinding -ServerName "WACServer.corp.contoso.com" -AllowHttp

Note: Anything above in you need to replace with the correct information from your farm.

  • Hi Lisa, I have tried removing OWA from the farm and recreated and re configured it. I have removed the bindings as well in SharePoint. But no use – Spoorthy Sep 24 '18 at 7:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.