0

When I add a document library (preview) to a modern site page in SharePoint Online, it adds the name field to the view even though it is not in the view in the default library:

Original Library Original Library View Settings View Settings, name is not checked Name appearing Name appearing in the view

Any recommendations? Has anyone else encountered this issue?

1

I can reproduce your issue.

It seems that the "Type (icon)" and "Name" field are the fixed fields that will always display in "Document Library (preview)".

Currently, there is no method to remove these fields. It is by design.

As a workaround, we can use “Embed” modern web part instead. Put the address of your library into the Embed textbox, it will display the library view (not whole page) from this address.

https://technet.sharepoint.com/sites/<site>/SitePages/Forms/pages.aspx

enter image description here

  • That workaround works, thank you for taking the time to reproduce. It's not the most aesthetically pleasing option so I may need to find a better way to recreate these pages. I'll be needed to display multiple views on a page to create a procedure manual. Thank you again for your help! – Ryan Sep 12 '18 at 12:49
  • this really needs to be addressed - it is pointless to have the option to hide the column if all it does is display an empty column that takes up all the space - also the column cannot be re-ordered, which is also useless. – barni Oct 10 '18 at 16:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.