0

I have added some custom fields to a Discussion Board list in SP 2013 that are populated using Workflow. I do not want these to appear in any of the create or edit item views.

I have marked the items as Hidden in the Settings: List Content Type but they are still showing in the NewForm.aspx and EditForm.aspx views.

Any ideas how to fix this?

UPDATE: Here is a view of what I have set the columns to in list content type; enter image description here

And here is how it is being displayed despite marking them as Hidden; enter image description here

  • 1
    Did you mark then hidden in 'Discussion' Content type ? – Bhaskar Dhone Sep 7 '18 at 9:27
  • @BhaskarDhone I don't appear to have permissions for the Discussion content type only the local instance of the list. I have added these custom columns to my local instance and with all other list objects, marking them as hidden works perfectly. It does appear to be a problem with the Discussion Board list. – unibod50 Sep 7 '18 at 9:35
  • Yes , I was talking about 'Discussion' content type of list only. This works when you mark them as hidden. Tested in my env. – Bhaskar Dhone Sep 7 '18 at 9:39
  • I've edited my post above - as you can see I have set the custom columns to Hidden as you describe but they are still not being hidden in the NewForm.aspx – unibod50 Sep 7 '18 at 9:53
  • 1
    I think I need my eyes testing. I hadn't spotted that there were 2 content types - having only ever seen one in normal lists. All fixed now - thanks – unibod50 Sep 7 '18 at 10:11
1

Discussion board has two content type. Discussion and Message You need to mark them as hidden in 'Discussion' Content type of list if you do not those fields in form on 'New Discussion' and mark then hidden in 'Message' content type if you do not want then in message i.e reply of discussion.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.