1

So we have a SharePoint Online document library set to open documents in the client applications

When opening the document using Chrome, a copy of the file is downloaded, saved to a local directory and opened using the Client Application. Users are only able to make changes and save the changes to the local copy. All is good with the world.

When opening the document using IE, it is opened using the Client Application but this seems to be connected to the online copy. enter image description here

Clicking on "Edit Workbook", we get the connecting to the server error above.

My understanding is that IE is downloading a temporary copy of the file which inherits the permission from the SPO document library. Most users don't have write access to the library.

The easiest workaround is to just manually save a local copy of the file, ie: File > Save As >...

Question: Is there a setting I can change to force IE to download a copy of the file instead of opening a temporary copy?

It's been suggested I use:

http://company.sharepoint.com/sitename/_layouts/download.aspx?SourceUrl=<document url>

but we have 1000s files.

0

Try checking in the Document Library Settings>Advanced Settings>Opening Documents in the browser. Does changing the Opening Documents in the Browser help?

Could browser settings be the issue otherwise? Try to compare IE with Chrome.

  • Thanks for the suggestion but it didn't help. I also compared the settings between IE and Chrome and there doesn't seem to be a setting in IE that suggest that there is an option to that'll let me change this. – hto Sep 10 '18 at 5:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.