1

I'm needing help with debugging error with Security Token Service on Sharepoint 2013

The SharePoint Health Analyzer

The Security Token Service is not available.

Event Error Output


An exception occurred when trying to issue security token:

The content type text/html; charset=utf-8 of the response message does not 
match the content type of the binding (application/soap+msbin1).

If using a custom encoder, be sure that the IsContentTypeSupported method is implemented properly. The first 1024 bytes of the response were:


'<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0        
Strict//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd"> 
<html xmlns="http://www.w3.org/1999/xhtml"> 
<head> 
<title>IIS 8.5 Detailed Error - 500.19 - Internal Server Error</title> 
<style type="text/css"> 
<!-- 
body{margin:0;font-size:.7em;font-family:Verdana,Arial,Helvetica,sans 
serif;} 
code{margin:0;color:#006600;font-size:1.1em;font-weight:bold;} 
.config_source code{font-size:.8em;color:#000000;} 
pre{margin:0;font-size:1.4em;word-wrap:break-word;} 
ul,ol{margin:10px 0 10px 5px;} 
ul.first,ol.first{margin-top:5px;} 
fieldset{padding:0 15px 10px 15px;word-break:break-all;} 
.summary-container fieldset{padding-bottom:5px;margin-top:4px;} 
legend.no-expand-all{padding:2px 15px 4px 10px;margin:0 0 0 -12px;} 
legend{color:#333333;;margin:4px 0 8px -12px;_margin-top:0px; 
font-weight:bold;font-size:1em;} 
a:link,a:visited{color:#007EFF;font-weight:bold;} 
a:hover{text-decoration:none;} 
h1{font-size:2.4em;margin:0;color:#FFF;} 
h2{font-size:1.7em;margin:0'..

UPDATE

I tried the below suggestion to browse to the http://localhost:32843/SecurityTokenServiceApplication/securitytoken.svc I was then able to receive the following error I'm still trying to work through how to resolve this.

ScreenShot

Any suggestion on how I should proceed will be appreciated nothing is jumping out to me when I inspect the web.config file.

1

Looks like STS's application pool or web is stopped, as i am seeing 500 error in the event. here what i would do.

  • Open a browser on server & browse this path "http://localhost:32843/SecurityTokenServiceApplication/securitytoken.svc" Do this on the server where it is failing.
    • If you are getting the XML output that's mean STS is working fine but may be you need to restart the app pool.
    • But if you are getting error, then make sure following things.
      • App Pool is up and running
      • App pool is running under farm account and password is up to date.
  • Thanks that, actually allowed me to get more information on the issue, Currently its giving me an error with the web config file on line <modules> 116: <add name="WindowsAuthenticationModule" /> </modules> – John DK Sep 6 '18 at 15:24
0

Suggested solutions:

1-Restart the Security Token Service application pool.

2-Check the event logs and ULS logs on all servers to find out which assemblies of the custom claims provider are missing then install the missing assemblies into the global assembly cache manually.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.