0

SharePoint search host controller and SharePoint Server Search 15 disabling every time I enable it. Reason I found that recently I have changed service account password which is used for those two services.

I do not know where all I should update this changed password. I tried to change the password in the central admin under Manage service accounts. but once I select my account and try to change password- upon clicking ok button its giving error as

The specified domain either does not exist or could not be contacted

ULS logs also saying same. Below is ULS recorded error.

"System.ComponentModel.Win32Exception: The specified domain either does not exist or could not be contacted at Microsoft.SharePoint.Win32.SPNetApi32.NetUserChangePassword(String loginName, SecureString oldPassword, SecureString password) at Microsoft.SharePoint.Administration.SPManagedAccount.AttemptPasswordChange(SecureString possibleCurrentPassword, SecureString newPassword) at Microsoft.SharePoint.Administration.SPManagedAccount.ChangePassword(SecureString newPassword, EventProcessingOptions eventFlags) at Microsoft.SharePoint.ApplicationPages.ManageAccountPage.BtnSubmit_Click(Object sender, EventArgs args) at System.Web.UI.WebControls.Button.OnClick(EventArgs e) at System.Web.UI.WebControls.Button.RaisePostBackEvent(String eventArgument) at System.Web.UI.PageProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)"

How to use Set-SPManagedAccount command to change the password ?

Error:- enter image description here

  • Couple of things: are you using the $ in your service accounts? is their any invalid / deleted account still exist in the managed account page? – Waqas Sarwar MVP Sep 6 '18 at 13:17
0

Password must be changed:

  • in Central Administration > Security > Configure managed accounts - click EDIT on account and Change password now

  • Try start Search Service, if it fails :

Check Windows Services and accounts here (update account with new password)

  • SharePoint Search Host Controller
  • SharePoint Server Search 15

If it fails again, look in IIS Web Service for account which are used on Search App Pool, update too.

If you want to use Set-SPManagedAccount:

$acc = Get-SPManagedAccount -Identity "domain\login"
Set-SPManagedAccount -Identity $acc -NewPassword "password"

enter image description here

enter image description here

I tried what you said but giving me the error. enter image description here

  • yeah i tried what you have mentioned from central admin and from shell command as well . But above mentioned error is coming "The specified domain either does not exist or could not be contacted" – Chetan Sep 6 '18 at 12:17
  • I added the powershell for changing password, otherwise, has your domain the same FQDN as short name? Something like : microsoft.com and MS\ ? or you can try add another account into Managed accounts if this works. – Zdeněk Vinduška Sep 6 '18 at 12:18
  • "No matching account found " error in SP PowerShell. used your command and this also same error. Set-SPManagedAccount -identity "AUTH\$account001" -NewPassword (ConvertTo-Securestring "abc.for-15" -AsPlainText -Force) -SetNewPassword – Chetan Sep 6 '18 at 12:27
  • you must firstly Get-SPManagedAccount and after this Set-SPManagedAccount. You have $ in account? Thats strange. Try add new account via Central Administration – Zdeněk Vinduška Sep 6 '18 at 12:35
  • i used Get-SPManagedAccount and got list of service accounts which has my required account too. If i try to add account its saying account exists. – Chetan Sep 6 '18 at 12:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.