I have a document library inside an online classic team site. the document library is linked to a term set using a site column named "Keywords" (internal name = "BibliographyKeywords"), as follow:-

enter image description here

And there is already a managed property created for me, inside the search schema for this site column, as follow:-

enter image description here

Now i want inside a modern page to show the documents (from certain sites) which are linked to certain terms inside the Keywords managed property column. so i find the new modern web part named "Highlighted content", which might help me in achieving this.So i define the following inside the "Highlighted content" web part, as follow:-

  1. for the Type i select "Documents"
  2. for the Filter and sort, i define the owstaxIdBibliographyKeywords managed property.

Here is screenshot of the "Highlighted content" modern web part settings:-

enter image description here

but i could not get things working, where i am facing these issues:-

  1. i got this result, which does not show any document, and not sure what this exactly represents:-

enter image description here

  1. second question , which is less important, now inside the document library i have defined a custom content type. but this cusotm content type is not showing inside the Type drop-down list. so does the "Highlighted content" web part's Type list only shows built-in Content types?.

enter image description here


I checked my crawl properties, and seems i have 2 crawl properties for the bibliographykeywords column, but seems only one of them is linked to the managed property, as follow:- enter image description here

also i checked the owstaxIdBibliographyKeywords managed property, and it has the 2 check-boxes "Queryable" & "Retrievable" checked. while the "Searchable" checkbox is uncheck. but on the mapping section of the managed property, i can not find any map to the above crawl property, although as shown above one of the crawl properties are mapped to this managed property. here is the mapping section inside the owstaxIdBibliographyKeywords managed property:- enter image description here

so can anyone advice on this please?

1 Answer 1


1) owstaxIdBibliographyKeywords is an automatically generated managed property but is not associated to any crawled property. Secondly, it is not set to Retrieve-able and Query-able. So, it doesnt contain any value in it and hence cant be used in your webpart.

You can find OOTB mulitple managed properties like RefinableString and can edit this Managed property and map it to the crawled property, which will be ows_BibliographyKeywords in your case and then wait for sometime for the crawl to pick up the values. After, that you can use the property like RefinableString10 in your webpart and it will filter values as per your requirement.

enter image description here

2) Yes, it only shows built-in content types and is not customizable since its OOTB webpart. But then in the webpart you can add additional filter using SPContentType as below:

enter image description here

  • thanks for your valuable info. now point 2 is clear to me. for point one can you check my edit, i added more info based on your reply.
    – John John
    Sep 8, 2018 at 16:33
  • 1
    for point 1, as i mentioned in the answer, find a RefinableString00 property and then map it to ows_BibliographyKeywords crawled property. After that, you can use it in your webpart Sep 8, 2018 at 17:24
  • so i have to use one of the available managed properties such as RefinableString00 or i can create my own managed property and give it a more user friendly name?
    – John John
    Sep 8, 2018 at 22:12
  • 1
    Yes correct. It should be mapped to ows_Bibliographykeywords crawled property, not the one with taxid Sep 9, 2018 at 4:12
  • 1
    Both are equally ok. I prefer RefinableString but you can create your own managed property and then consume it. For RefinableString, you can set the alias as a friendly and unique name and use it in the webpart i.e instead of RefinableString you can use its alias in the webpart Sep 10, 2018 at 5:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.