0

On List libraries that have a Choice field, with the "Allow 'Fill-In Choices" option enabled; after you make a selection and click on a different field:

a) The selection you make is cleared and the field reverts to being empty. b) The list gets a new empty entry at the bottom of the list.

If I disable "Allow 'Fill-In Choices" on the field and then re enable it, all my previously filled in choices are erased, the erroneous empty values are erased, and the problem returns.

This is happening on two different SharePoint Online sites, and across multiple list libraries. The feature was working previously (prior to the time of this posting), and seems to have only appeared this week (or even today).

What would normally be the cause of this problem?

I made a gif of the problem

  • Microsoft has an advisory in the Office Admin Portal "SP147620 - Items not saving when 'Fill-in' feature enabled"; so they are working on it. – user77232 Sep 6 '18 at 15:01
  • Microsoft has fixed the problem in production. – user77232 Sep 10 '18 at 14:32
  • issue: Fill in option is not working Description: when building a list in sharepoint and selected the multiple choice filelds and allowing fill in options the fill in option is not working properly. I was unable to find any resources on the issue and does appear that the has been setup correctly the fill in option just is not working Please let me know how to resolve this issue – Siva Uppalapati Aug 13 '19 at 14:11
0

I can reproduce it.

Cannot find the cause. Maybe there are some operations or updates in the backend cause it.

You can create service requests to contact Office 365 support.

How to contact Office 365 support

Provide as much additional information as possible to describe your issue.

Some Workarounds:

  1. Customize forms using PowerApps.
  2. Display choices using radio buttons instead of drop down menu.
  3. Use a managed metadata field with Allow Fill-in instead of using a choice field.
  4. Use Classic experience rather than New (modern) experience.
  • So it's not just me; something is wrong. I was really hoping it was a setting that got turned off during an update. – user77232 Sep 6 '18 at 10:04
  • I like your work arounds. – user77232 Sep 6 '18 at 15:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.