1

I am creating a site (using SharePoint 2010) where users can submit a nomination for review into a SharePoint library. In SharePoint designer I customized the default form. Everything is working properly, but the only issue I am having is that when a user goes to press save the page sits there for awhile. Sometimes it will eventually save and go to the library with the information submitted in the library and other times you press save and have to close out the browser and come back and the information is still there. I am wondering if anyone has any thoughts on what this issue might be? I thought it might just be my computer, but I have tested it on a number of them and the same issue occurs.

Thanks!

  • Is there a workflow running on the list? – C. Dennett Aug 30 '18 at 15:58
  • yes there are multiple workflows and this in a library not a list – Madeline Faunce Aug 30 '18 at 23:05
  • Do you think that the workflows are causing the issue?? – Madeline Faunce Aug 31 '18 at 14:30
  • Yeah, that would be my guess. See if you can open one of the items that saved, and check the Workflow status. Select or open the item, and click the "Workflows" option in the Ribbon. You should see a page that looks similar to this screenshot I took (imgur.com/ErEehlY). Look particularly closely at the Start Time and End Time of each workflow or step, and hopefully one of them will show you why some take so long, and some fail. – C. Dennett Aug 31 '18 at 19:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.