1

I've setup an App in Azure using instructions from various places, including: http://www.ktskumar.com/2017/01/access-sharepoint-online-using-postman/ http://tech.bool.se/basic-rest-request-sharepoint-using-postman/

I've successful authenticated using the client_credentials flow and received an access token: enter image description here

However, when I tried to call various endpoints, I always get a 403 error: enter image description here

Tried other endpoints such as https://cityofstirling.sharepoint.com/_api/contextinfo but all resulted in the 403 error.

I've granted full access to collections for the App. Does anyone have any ideas that I could explore further? Thanks for your help.

  • you might want to add the version of SharePoint you're using and the how authentication is set up. – Derek Gusoff Aug 30 '18 at 14:14
0

Please go through this article which is posted by "Shantha Kumar Thambidurai". He explained very clearly, about calling the SharePoint API from Postman.

http://www.ktskumar.com/2017/01/access-sharepoint-online-using-postman/

0

Thx for that link. It was one of the links that I posted initially. I managed to solve the issue. My error was that I used the "App Registration" function within Azure rather than using the linked App Registration:

https://.SharePoint.com/_layouts/15/appregnew.aspx

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.